You are not logged in.

#1 2019-05-31 08:42

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 710

Gdebi permissions issue on Centaurus

Just went to install a package on Centaurus using gdebi

Normally (pre Centaurus) it would ask for password after clicking Install - now it just crashes.

Running from CLI

 Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done

Master PDF Editor is the complete solution for viewing, printing and editing PDF files.
............
Need to be root to install packages

What it seems is that the installer is unable to find the correct path to whatever is need to launch the admin password box.
Don't know if this is due to background re-routing of tdesudo or something else.

Easy workaround obviously - but curious.

Offline

#2 2019-05-31 09:42

jotapesse
Member
From: Algarve, Portugal
Registered: 2019-03-23
Posts: 67

Re: Gdebi permissions issue on Centaurus

HI!

No issues here, on my Centaurus install, running on terminal. Did you use "sudo"? Also, via GUI no issues, it asks for administrative password.

$ sudo gdebi /var/cache/apt/archives/ne_3.1.2-1_amd64.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done

easy-to-use and powerful text editor
 Ne, the nice editor, is one of the few text editors being
 both easy to use for the beginner and powerful enough for
 the wizard, supporting UTF-8 and multi-column characters as
 well as syntax highlighting.
 .
 It uses short, intuitive and easy to remember key bindings
 while providing all the features an editor should have.
 It is fully configurable allowing the user to change the
 content of the various menus, to easily create small macros
 and to easily change the existing key bindings while being
 a small and fast editor.
Do you want to install the software package? [y/N]:y
/usr/bin/gdebi:113: FutureWarning: Possible nested set at position 1
  c = findall("[[(](\S+)/\S+[])]", msg)[0].lower()
Selecting previously unselected package ne.
(Reading database ... 364953 files and directories currently installed.)
Preparing to unpack .../archives/ne_3.1.2-1_amd64.deb ...
Unpacking ne (3.1.2-1) ...
Setting up ne (3.1.2-1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for menu (2.1.47+b1) ...

Last edited by jotapesse (2019-05-31 09:43)


jotapesse - Obrigado / Thank you.

Offline

#3 2019-05-31 09:58

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 710

Re: Gdebi permissions issue on Centaurus

Interesting. I have done this on 2 different machines and also from live media with gdebi installed - always the same result.

What happens on your machine if you try to install a package after login - in other words not having used sudo at all?

Are you using Trinity or Plasma? I'm on Trinity.

Offline

#4 2019-05-31 10:31

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,450
Website

Re: Gdebi permissions issue on Centaurus

You probably need have "policykit-1" installed and do a new login for Polkit service to be started, as gdebi binary requires "pkexec" agent. We will check that and post back.

Offline

#5 2019-05-31 11:22

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,450
Website

Re: Gdebi permissions issue on Centaurus

Yes, we are able to reproduce as well as workaround the issue. The "polkit-kde-agent-1" package is missing in Trinity core install, so you only need to install it and do a new login. We will include the package into one of installation profiles. Thanks for the report.

Offline

#6 2019-05-31 13:04

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 710

Re: Gdebi permissions issue on Centaurus

Thanks very much for the quick response team!

Offline

Board footer

Powered by FluxBB